martes, marzo 04, 2008

Validar números de cédulas de Nicaragua con JavaScript

A continuación comparto un pequeño código JavaScript para validar si una cadena de texto es un número de cédula válido en Nicaragua.

Siéntanse en la libertad de usarlo, modificarlo, copiarlo o compartirlo. Se ha liberado como L-GPL3.

http://sites.google.com/site/denisjtorresg/validar_cedula_js.zip

Ver versión para Java.

7 comentarios:

  1. Aquí te dejo algo que realice en Excel para un string sin guiones:

    =SI((EXTRAE(A2,14,1)=EXTRAE("ABCDEFGHJKLMNPQRSTUVWXY",(VALOR(EXTRAE(A2,1,13))-TRUNCAR(VALOR(EXTRAE(A2,1,13))/23)*23)+1,1)),"Numero Correcto", "Numero Incorrecto")

    Prácticamente para validar la ultima letra

    Saludos Hector Alvarez C.

    ResponderEliminar
  2. Crees que pueda conseguir un comprimido del padron electtoral

    ResponderEliminar
  3. Hola José, no tengo idea si se pude conseguir.

    Saludos

    ResponderEliminar
  4. hola gracias por el código lo estuve buscando.
    Una pregunta, se que el significado de las tres primeros caracteres es el municipio del departamento, por casualidad vos tenes todos los tres primeros digitos con su respectivos municipio? por ejemplo 001-Managua-Managua, 122-Acoyapa-Chontales, 121-Juigalpa-Chontales, etc. (estos son los que conozco) Sera que vos los tenes todos???

    ResponderEliminar
  5. Hola José,

    No tengo dichos códigos.

    Saludos

    ResponderEliminar
  6. Hola Denis, fijate q probando tu codigo usando el formato 000-000000-0000A y me dice que la letra no es valida por consiguiente la cedula me dice q no pasa la prueba.. a que se debe......... gracias

    ResponderEliminar
  7. Hola

    Para el ejemplo que has enviado (000-000000-0000A) el error que genera el programa dice que la fecha no es válida, y está en lo correcto.

    La fecha debe cumplir esta expresión regular:

    new RegExp("^(0[1-9]|[12][0-9]|3[01])(0[1-9]|1[012])([0-9]{2})$");

    Respecto al último carácter de la cédula, este corresponde con un código de verificación o checksum, el cual se calcula o determina en base a todos los números previos (ver el código fuente del archivo js).

    Este código de verificación asegura que al suponer códigos de cédulas al azar solamente el 4% (1/23) sean consideradas válidas, lo cual ayuda a evitar errores de digitación en los sistemas y le da más fiabilidad al código de cédula.

    Saludos

    ResponderEliminar